We are continuing to monitor for any further issues.
Posted Oct 29, 2025 - 15:31 EDT
Monitoring
A fix has been implemented to fail over and bypass the affected infrastructure services. The team is actively monitoring as the Customizer API becomes available and stabilizes.
Posted Oct 29, 2025 - 13:57 EDT
Identified
Drive services — including Customizer, Cartographer, and Pacenotes — rely on Microsoft Azure for their underlying infrastructure. As of 12:00 PM ET on October 29, 2025, these services began experiencing degraded performance. Microsoft engineers are currently investigating the root cause. You can follow ongoing updates at: https://azure.status.microsoft/en-us/status
Posted Oct 29, 2025 - 12:51 EDT
Investigating
We are currently investigating the issue with the underlying infrastructure provider.
Posted Oct 29, 2025 - 12:14 EDT
This incident affected: Customizer, Cartographer, and Pacenotes.